Best practices are an essential part of our curriculum. When creating Fluid pages, we recommend the following page name pattern:
For example, when creating a Fluid subpage to manage widgets, we would name it
JSM_WIDGETS_SBF. Here is a list of page-type suffixes derived from Oracle-delivered pages:
- Fluid Page
- Subpage Fluid
- Secondary Page Fluid
- Side Page (1 or 2)
- Footer Page
- Layout Page
But four more page types aren't used enough to have a suffix pattern: Header Page, Search Page, Prompt Page, and Master&Detail Target Page. For those page types, we've come up with our own suffixes:
- Header Page
- Search Page
- Prompt Page
- Master&Detail Target Page
For the most part, the convention is easy to understand. First initial of page type, and then FL. But what about SRF? Where did that come from? There are four page types that start with the letter S. Adding the R after the S looked more like Search than any of the other options we considered.
With Classic already having the suffixes SEC, SUB, and POP, we have suffixes for every page type except Classic standard pages. Should we, therefore, adopt _CL for Classic pages? PeopleSoft uses exception-based design. For example, the page bar is on until you turn it off, and the standard component toolbar is on until you turn it off. Changing these properties would be exceptions. Naming conventions are no different. Our naming conventions document the exceptions. With over 12,000 Classic pages in HCM, Classic is clearly the norm, and everything else is an exception.
What do you think? Do you have different naming conventions you use for page development? If so, share your ideas in the comments!
At JSMpros, we teach PeopleSoft Fluid training and best practices regularly. We look forward to hosting you in a future class!
There should be a visual indicator, maybe on the title bar, indicating the sub-type of object, so that you don't have to dig into an additional properties window.
Also, the open/search dialog should give you an option to search for each type of object's subtype.
Then this naming convention which eats into the already short name could be abandoned and a more descriptive name could be used for the object.
Thanks and keep up the good work Jim,
@Alexei, really cool idea! Have you added it to Idea Labs?
Post a Comment